Wednesday, June 27, 2012

6. Install NetFPGA Base Package

1.  Install the NetFPGA yum repository and GPG key using the following command :
rpm -Uhv http://netfpga.org/yum/el5/RPMS/noarch/netfpga-repo-1-1_CentOS5.noarch.rpm
2. Then run the following command to install the NetFPGA Base Package (if you are trying to implement any routers mentioned in step 3, do not run this command) :
yum install netfpga-base
(This command installs the latest version of the netfpga-base which is currently 3.0.1)

3. Different types of routers that I have tried implementing are as follows and mentioned in the brackets is the version of teh NetFPGA Base Package required for that router :
  a - IPv4 Reference Router (v2.1.1)
  b - DRAM Router (v2.1.1)
  c - Fast Reroute & Multipath Router (v2.0)
  d - PTP-Enabled Router (v2.0)
  e - Promiscuous Reference Router (v2.0)
  f - Flexible Router (v2.0)
  g - Deficit Round Robin Router Backplane (v2.2)
  h - RCP Router (v2.0)


For v2.0, use the command :
yum install netfpga-full-2.0.0-beta_full.i386

For v2.1.1, use the command :
yum install netfpga-base-2.1.1-full

For v2.2, use the command :
yum install netfpga-base-2.2.0-full

12 comments:

  1. Hey man! Great step by step guide you have!

    I’ve been having quite a few issues getting the NetFPGA to run on my system and I have a short question concerning this step. If I want to change version packages, do I have to uninstall a previous version which is already installed? How do I go about removing all the loaded drivers and stuff?

    ReplyDelete
    Replies
    1. thnx.. :)

      if u r installing a newer version, i don’t think you’ll have to uninstall the previous version since they r supposed to be compatible with the older base packages.. but then it also depends on wht u r tryin to implement on the board.. for removing the drivers u can use the ‘yum remove’ command.. search for packages with netfpga in them and try manually removing them although this wasn’t of much help to me as i landed in a mess of dependencies.. :D i had to re-install the os n that’s a really hectic task.. i think manually removing the packages shud do it too.. sry for not being of more help.. good luck with ur project.. :)

      Delete
    2. Harichandan, what if i want to use this as a switch. What version do i need to install?
      thanks

      Delete
  2. Hi. I’m getting this error

    [root@localhost yum.repos.d]# rpm -Uhv http://netfpga/org/yum/el5/RPMS/noarch/netfpga-repo-1-1_CentOS5.noarch.rpm
    Retrieving http://netfpga/org/yum/el5/RPMS/noarch/netfpga-repo-1-1_CentOS5.noarch.rpm
    curl: (6) Couldn’t resolve host ‘netfpga’
    error: skipping http://netfpga/org/yum/el5/RPMS/noarch/netfpga-repo-1-1_CentOS5.noarch.rpm – transfer failed
    [root@localhost yum.repos.d]#

    I’m currently working with CentOS6.2. Is this the reason for the above error.What should i do now

    ReplyDelete
    Replies
    1. using CentOS6 could be a problem because the developers of NetFPGFA might not release the latest versions at the same time as that of CentOS.. so you might have trouble finding the packages.. but i see that they have released the yum repository for CentOS 6.. check out this link and follow the steps.. https://github.com/NetFPGA/netfpga/wiki/InstallSoftware12 .. hope that helps

      Delete
    2. thanks for ur reply! :)

      Delete
    3. I am using CentOS 6 too. I can't find yum repository for it.... Can u please give me exact command that I should use?

      Delete
  3. Thanks for ur previous reply. We continued with the next step but getting this error.

    [root@it46 ~]# rpm -Uhv http://netfpga.org/yum/el5/RPMS/noarch/netfpga-repo-1-1_CentOS5.noarch.rpm
    Retrieving http://netfpga.org/yum/el5/RPMS/noarch/netfpga-repo-1-1_CentOS5.noarch.rpm
    error: skipping http://netfpga.org/yum/el5/RPMS/noarch/netfpga-repo-1-1_CentOS5.noarch.rpm – transfer failed – Unknown or unexpected error
    warning: u 0x84d2300 ctrl 0x8be20d8 nrefs != 0 (netfpga.org http)

    What should we do now….Can u pls guide us.

    ReplyDelete
    Replies
    1. what this command is trying to do is to download a package from a repository and unpack it simultaneously.. since thts not working for u, u can do them separately.. first download the package by clicking on the link.. then go to the directory where tht file’s downloaded and use ‘ rpm -Uhv ‘..

      Delete
  4. Hi. I used this command to install netfpga base package yum install netfpga-base-2.1.1-full, but netfpga-kernel installation failed. Other components are installed succesfully. During installation of netfpga kernel I got these error:

    make -C /lib/modules/2.5.18-194.el5/build M=/usr/local/netfpga/lib/C/kernel LDDINC=/usr/local/netfga/lib/C/kernel/.../include modules
    make: *** /lib/modules/2.6.18-194.el5/build: No such file or directory. Stop.
    make: *** [modules] Error 2

    Please help!!! :)

    ReplyDelete
    Replies
    1. In first line that starts with make should be 2.6.18-194.el5. I made mistake.

      What to do now?

      Delete
    2. don't worry abt the first line of make output.. tht shud b fine..

      afaik prob with netfpga-kernel shud not b a prob.. proceed to kernel updation.. i think it shud b fine..

      Delete